Back to LanguageTool Homepage - Privacy - Imprint

Installing server engine on Centos7

I am trying to get this working on a server. But when I follow these instructions for installing it here
http://wiki.languagetool.org/http-server

When I exec the command

java -cp languagetool-server.jar org.languagetool.servTTPServer --port 8081 --allow-origin "*"

I can see on th server it is listening, but I cannot access it via the browser or its api. When I scan the port 8081 is not open.

when I try

netstat -tlpn | grep 8081

I get this
tcp6 0 0 127.0.0.1:8081 :::* LISTEN 17952/java

It is like it is not listening on ipv4? Am I seeing this correctly?

How can I get this working? and how can I et this as a daemon?

Have you tried the --public flag?

1 Like

@dnaber
Thank you so much for your reply. I have just tried the --public flag and it worked! It actually switched the port to 808.

Do you know how we could run this as a service? I mean presently I’ve executed this in the background using &, so:

java -cp languagetool-server.jar org.languagetool.server.HTTPServer --port 808 --public 1 --allow-origin "*" . &

and it seems to be ok - I just want to make sure there is not a better way so I can enable this on boot as well like a daemon service.

Thanks again!
Guy

There was recently a thread about that at How to properly supply languagemodel argument in systemd