Back to LanguageTool Homepage - Privacy - Imprint

Invalid markup position for FireFox 77.0.1

Invalid markup position on LanguageTool FireFox extension. FireFox 77.0.1

https://www.linux.org.ru/news/openoffice/15782743?cid=15783159

Hi @Yakov, thanks for reporting this. Unfortunately, we are unable to reproduce this with the same text on linux.org.ru.
Could you let us know which other plugins you have installed in your browser?
Also, it would be nice if you could right click on the text field and select “Inspect element” and then take a screenshot.

Thanks in advance.

Hello, can confirm similar issue. FF 77.0.1

@nebm51 which website is that happening with?

@nebm51 @Yakov does the problem also happen on other websites?

This is gitlab installation in my company.

Some stats:

  • this forum - no issue
  • linux.org.ru - no issue
  • facebook - no issue
  • youtube - no issue
  • livejournal - has an issue
  • trello - no issue
  • my company gitlab - has an issue
  • gitlab.com - no issue

@nebm51 Thanks. Is the website where it is happening maybe zoomed in or do you have some custom text zoom settings in your Firefox?
Does it also happen on this simple text field? https://languagetool.org/development/simple.html

@tiff thanks for a hint. Looks like highlighting offset is connected to zoom level. It moves to right if zoom is increased, and to left if it’s reduced.

I’m on a Mac and can’t reproduce it.

@nebm51 how are you zooming? Via CTRL +/-? Does it happen on the simple text field I sent you (https://languagetool.org/development/simple.html)?

I’m on Mac too. Doing a zoom with CMD +/-

On https://languagetool.org/development/simple.html with zoom it looks like this:

I have done screen recording with different zoom levels, where can I upload it, if it helps?

@nebm51 I think I could finally reproduce it. I had to check the checkbox “Zoom text only” in the Firefox settings. Is your Firefox configured the same?

@tiff yes, you are right. I have a checkbox “Zoom text only” enabled. Temporarily unchecked it and tested, in this case highlighting works fine with any zoom level and site.

1 Like

@nebm51 great. Thank you for helping us here. We will try to provide a fix for this (if possible).

@Yakov do you have the same setting in your Firefox?

Yes, I confirm that this problem appears if the checkbox “Zoom text only” is set on.

1 Like

@Yakov @nebm51 as of last week the fix is live (v3.1.8). Our add-on now fully respects the “text zoom” feature of Firefox.

@tiff Thanks a lot! Can confirm, that its working fine now.

1 Like

@tiff Can confirm, that it’s working right now.

This might also be the zoom factor again (maybe).

It was, we were able to fix it.