Back to LanguageTool Homepage - Privacy - Imprint

Is my installation correct?

In LibreOffice version 6.4.6.2 I installed LanguageTool version 5.1.3. This seems the last user version. The newer versions seems to be developer version. I tried that before, it failed, and now I use 5.1.3. My OS is Ubuntu 20.04.

The installation seems to be ok. In LibreOffice Menu -> Tools -> Extension manager -> I see LanguageTool-5.1.3.oxt without an error message.
But I do not see a window with 4 LanguageTool icons to check my text. To verify I copied the text, with spelling errors, in the Dutch language, from https://languagetool.org/ in LibreOffice. But in LibreOffice is do not see all spelling errors as I see on your website. So it seems the installation is not correct. Is there a way to check this? And, if so, hopefully correct the installation.

The extension for LibreOffice does not check spelling (unlike the standalone version), only grammar.

Try checking a sentence with a grammar error. Note, however, that different languages have different levels of support, some have only very basic rules.

I copied the example grammar error on the main LanguageTool page of the Dutch language in LibreOffice. It did not find the grammar error.
Do you know what the level of support is for Dutch compared to the online level. Which seems to be quite good.

When I switch to Dutch at the languagetool site, I see no sentence.

In addition: I tried to check some text from Wikipedia with several installations of LT on LO. I succeeded only with a 5.1 snapshot, LT found a couple of errors (I don’t know if they are real errors, for example, if zeer enthousiast is an error, but it is detected), while 5.2 and a 5.3 snapshot failed with a message of “Linguistic services failed! LanguageTool cannot be started”. As I can see, such a message is reported by other user(s), thus, it might be an issue with LanguageTool.

Sometimes at https://languagetool.org/ there is a default Dutch text, sometimes none. There reason why is unknown to me.

My previous installation was of LT version 5.2.2 I then I also got the message:
“Linguistic services failed! LanguageTool cannot be started” . see https://ask.libreoffice.org/en/question/290952/linguisticservices-failed-using-languagetool/

zeer enthousiast seems to me no error. If it would be an error at least I need an explanation of LT to be able to identify if that is correct.

Is there a way to identify if my installation is correct? f.e. the windows with a block of 4 grey icons to check the text.

I have an impression that the problem is about LT (thus, asking at the LO Ask site is of little use). I made some additional tests with LibreOffice 6.3.6.2 / Windows 7 and LT extensions downloadable from the LO extension site to find that:

  • LT 4.1 works fine;
  • LT 5.1.3 works fine;
  • LT 5.2.2 does not work.

@Gabix Thanks for your investigation. You have experience with LT and know what to expect. If it returns what you expect it works fine, otherwise it fails. But I am total new to LT so I do not have that experience.

So my ultimate question is: Is there a kind of self test, in Ubuntu, for LT?

But you have already done a good test: you have tested the sample phrase from the LT site (when I got no sample for Dutch, I had to reload the page and the sample was there). You did the right thing!

To make sure, uninstall your current version of LT, go to the extensions page (see above), get and install 5.1, test with that version.

A very basic universal test: type in a repeated word (any should be good, even het het) and see if it is detected.

This getting complicated. The repeated word was not detected. So I try to uninstall LT from LibreOffice. This was impossible. See the screenshot:

As you can see in the screen LibreOffice was in the process removing LT.

This means LT did corrupt one way or the other LibreOffice.

So I uninstalled LibreOffice all the way and re-installed it. Now I have got LibreOffice version 7.0.4.2
I checked again twice the same word, but it was not detected. Now I want to install LanguageTool again but it was already installed (version 5.1.3) This seems the default configuration with LibreOffice.
Just try to use LT, just try to install LT requires much more then I expected.
What can be the next step?

It looks like you have to reset your user profile or at least the extensions part of it.

Sorry I am lost. Just using a tool, which in LibreOffice 7.04 is already preinstalled does not work. I was forced to re-install LibreOffcie due to LanguageTool and I was not happy with that. LanguageToo is just not robust, at least the installation part.

Do you know what the level of support is for Dutch compared to the online level. Which seems to be quite good.

Zeer enthousiast is wat overdreven.

By the way, not all double words render an error. Je je is perfectly okay, e.g.

Thanks for your reply. A good tool should be robust, just to install. Of course environments of different users differ, so results may be different. But then LanguageTool should have a build in selftest, https://en.wikipedia.org/wiki/Built-in_self-test which could point directly what is expected and is not available on that specific machine. I gave up trying to install LanguageTool. Please accept my choice.