Back to LanguageTool Homepage - Privacy - Imprint

Issue with Bitbucket's platform text fields

There is an existing issue with integration LanguageTool extension on Firefox with text fields used in Bitbucket (repository platform developed by Atlassian). When user tap the corrected value, it’s inputed on the beginning of the whole text.

Thanks for the report. Could you send a URL and/or a screenshot where this happens? I just tried in the bitbucket wiki, but I couldn’t reproduce the issue.

Sure, I’m attaching screenshots, as I probably couldn’t when creating the topic. It occurs when you add a comment to the code line in Pull Request. Screenshots below are step by step reproduction. As a new user I cannot attach the files, I uploaded it to the imgur.

Bitbucket comment issue

I’m leaving also my environment specs:
macOS Big Sur
Firefox 88.0.1

Do you have a publically accessible URL where to reproduce this?

Nope, it’s hidden under internal company access. It can be reproduced by creating Bitbucket repo for free, commit some code and prepare a pull request, but it can take some time to do it. If you can, share some details of needed reproduction, catching the logs etc. and I can try to provide you some details from mine.

A screenshot that shows the full screen might help. When I tried to reproduce, I ended up with screens that look different from what’s in your screenshots.

It’s under the path

*pull-requests/*

Below the full screenshot with censored company fragile data:

The field looks different for me and I can’t reproduce the issue. Can you reproduce it here (a public repo)? Do you use bitbucket.org or a self-hosted version?