Back to LanguageTool Homepage - Privacy - Imprint

Java exception

I’m having Java exception problems. One response on the forum suggested installing the latest version of Java, but I already have that version in place. I’ve tried removing and disabling the LibreOffice extension, but neither action works. How I proceed from here?

What error exactly do you get? Have you tried the suggestions listed at https://languagetool.org/issues?

dnaber, I looked at the suggestions, but nothing seems to help.I do have screenshots–how do I attach them?

I think you can just drag and drop them into the text area where you reply.

OK,dnaber, here’s one,…

…and here’s the other.

As it says Path /de/removed.txt not found, are you sure that the download was good? Have you tried reinstalling with a fresh download of LT?

dnaber, I downloaded the current version of the add-on, and tried to install it. The installation did not complete, and I received the following message"

I cannot help much with that, but the advice from our page might help:

If you get Failed to load rules for language … Caused by java.lang.ClassNotFoundException: Loading rules failed: Duplicate class definition : For some reason LanguageTool is installed twice as an extension in OpenOffice.org. You can try deleting the directories listed in the error message after making a backup. (The directories to be deleted have random names like “EE31.tmp_” or similar - exit OpenOffice.org before deleting anything).

(the same should apply for LibreOffice)

dnaber, I finally managed to get Java installed. I have tried several times to delete the LT LO extension, but it always comes back. What next?

dnaber, I think I’ve solved the problem: I totally uninstalled and reinstalled Libre Office, and now everything works–including Language Tool.

Thanks for your time, effort and patience.

dnaber, I spoke too soon; after reinstalling both LT and LO, I’ve still got the problem. Any other ideas?