Back to LanguageTool Homepage - Privacy - Imprint

LangeTool add-on for Writer not working after changing display settings

Hello there.

Some time ago I tried to change LanguageTool settings for the way errors are displayed in LibreOffice Writer, and since then the add-on is not working at all. If I remember well, the thing that I changed and that caused all this mess was the settings for the underlining —I selected a bold line instead of a thin one. That was it.

I have tried to uninstall and reinstall both the add-on and LibreOffice several times unsuccessfully. I have also tried installing older versions for both LT and Libre, as well as updating Libre with the latest versions launched since the add-on stopped working (now, 7.1.4.2). None of that works. And of course there is no way to access the LT add-on settings —it just won’t work, settings window won’t show in Writer.

That is the error displayed every time I open a document in Writer:

And that is the complete version info for Writer:
Version: 7.1.4.2 (x64) / LibreOffice Community
Build ID: a529a4fab45b75fefc5b6226684193eb000654f6
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: ca-ES (ca_ES); UI: ca-ES
Calc: threaded

I have looked it up on Google and the one instance I found with that exact error message is a GitHub page with a code I frankly do not understand (languagetool/Configuration.java at master · languagetool-org/languagetool · GitHub).

Is there any way to completely remove the add-on info so I can reinstall it from scrap and get rid of this error? Any help would be much appreciated…

Just deleting Languagetool.cfg might be enough. This should reset your configuration. The file location depends on your OS I think, your best bet is to just search for the file name and delete it (but keep a backup).

Wow it worked! It seems easy now, but I was seriously about to give up… Thank you very much!

(On Windows, cfg file is in C:\Users[user]\AppData\Roaming\languagetool.org\LanguageTool\LibreOffice)