Back to LanguageTool Homepage - Privacy - Imprint

Language tool 1.8 won't install


(Brian) #1

I get the error message "Could not create Java implementation loader" when I try to install Language Tool 1.8. I have tried the fix in the "Common Problems" but it still won't install. I am running Vista and OO 3.4.1


(Daniel Naber) #2

Am Fr 07.09.2012, 13:52:10 schrieben Sie:

I get the error message "Could not create Java implementation loader"
when I try to install Language Tool 1.8. I have tried the fix in the
"Common Problems" but it still won't install. I am running Vista and OO
3.4.1

Unfortunately this is one of the problems we know about but cannot
reproduce.

Do you get a more verbose error message if you try to install LT like this
on the command line?:

unopkg add LanguageTool-1.8.oxt --verbose


(percy) #3

I believe this problem might be related to LO not knowing where Java is installed. I get the error message also. Afterwards, when I exit LO and then re-start it again I get a Java error message. When I go into the LO options/settings, it no longer lists the Java location.


(percy) #4

Here is what I get after trying to install LT 1.8 as an extension of LibreOffice under Windows 7 (64-bit):

Could not create Java implementation loader

After I exit LibreOffice and re-start it again, I get the following message:

LibreOffice requires a runtime environment (JRE) to perform this task.
The selected JRE is defective. Please select another version or install
a new JRE and select it under Tools - Options - LibreOffice - Java.

(Daniel Naber) #5

On So 16.09.2012, 18:22:23 you wrote:

Here is what I get after trying to install LT 1.8 as an extension of
LibreOffice under Windows 7 (64-bit):

Can you try a 32bit build of Java (as suggested on
http://www.languagetool.org/issues/)?

Regards
Daniel

--
http://www.danielnaber.de


(percy) #6

Thanks! That suggestion worked. Both error messages went away and Language Tool now works.