Back to LanguageTool Homepage - Privacy - Imprint

Language tool keeps changing to German

Hey Guys, not sure if this is a bug. Have been using LT for years now, and it has just switch to German from English. I can see in the settings it is English. I have tried removing the tool and re adding it, it still randomly switches over throughout the day.

Any idea what might be causing this?

Language setting in Firefox = English.
Language setting in LT = English.
Language setting in Windows = English.


Hi Sam, thanks for the report. Could you send an example text and a screenshot when this happens?

Hey Dan,

Please see the attached screenshot.

That’s not German :slight_smile: Anyway, the text might just be too short to be correctly detected. Please follow the instructions here to make sure only those languages are set that you actually use: A wrong language is detected (e.g. English when I write Dutch) : LanguageTool

1 Like


It started doing the changing language thing again, checked settings - It’s set to English.

Could you please send the full text, so we can reproduce the issue?

Here’s another example: “18-Mar-22 1:05 PM - munro comptuer”



18-Mar-22 10:57 AM - backups 01 emila permissions

Another one:

30-Mar-22 2:42 PM - metro project itune

New user here. First day and so far pretty useful… except this problem has quickly it has become a nuisance.


I have English (American) set as my default and native languages. As @dnaber mentioned, perhaps it’s just too short of phrases. However, I don’t think “donate” is Italian, so I’m not sure why it assumes so. :woman_shrugging:

Hi, which languages have you set here in the add-on?

Hello - sorry for my delay… I have English (American) set as my Mother tongue and Preferred languages. Screenshot: CleanShot 2022-07-15 at 15.24.54 - language tool settings set to english · CleanShot Cloud

And here’s another example of this issue happening. It assumes “Privacy Policy” is Polish - CleanShot 2022-07-15 at 15.22.58 - language tool not detecting english · CleanShot Cloud

Sorry, I cannot reproduce this yet. Does it also happen when you type Privacy Policy in the text box here? LanguageTool browser add-on test