Back to LanguageTool Homepage - Privacy - Imprint

Language Tool läuft nicht unter Win mit 64bit ("Could not create Java implementation loader")


(Michael G.) #21

Ich habe gerade versucht, folgendes zu installieren:

PC mit Betriebssytem Win Vista 32 Bit
Java 7 Update 7
OpenOffice.org 3.4.1

Languagetool 1.9 lies sich jedoch nicht installieren.

Ich habe versucht, Languagetool über einfachen Doppelklick zu installieren, oder alternativ über den Extension Manager von OpenOffice.
Das Ergebnis war jeweils die Fehlermeldung: “Could not create Java implementation loader”.

Der Fehler tritt somit nicht nur bei Windows-Systemen mit 64 Bit auf.


(Daniel Naber) #22

Die Leute von Zotero, die das gleiche Problem mit ihrer Extension haben, haben hier nochmal die möglichen Lösungen aufgelistet:

http://www.zotero.org/support/word_processor_plugin_troubleshooting#could_not_create_java_implementation_loader


(Michael G.) #23

Betriebssytem Win 64 Bit
Java 7 Update 7
OpenOffice.org 3.4.1
LanguageTool-1.9

Ich habe gerade wie auf der “Zotero-Seite” beschrieben Microsoft “vcredist_x86” auf meinem System installiert. Danach konnte ich LanguageTool-1.9 ohne Fehlermeldung installieren. Es scheint auch vollständig in Apache OO integriert zu sein. Nach einem Test mit falscher Grammatik, wird dieser Fehler jedoch nicht erkannt. Der Fehler wird nicht mit einer blauen Wellenlinie unterstrichen.


(Michael G.) #24

PROBLEM ist GELÖST (durch Neustart des Systems)!

Installiert war:
Betriebssytem Win 64 Bit
Java 7 Update 7
OpenOffice.org 3.4.1

Danach habe ich wie auf der “Zotero-Seite” (http://www.zotero.org/support/word_processor_plugin_troubleshooting#could_not_create_java_implementation_loader) beschrieben “vcredist_x86” ( http://www.microsoft.com/de-de/download/details.aspx?id=8328 ) installiert. Anschließend konnte LanguageTool-1.9 installiert werden, ohne dass die Fehlermeldung “Could not create Java implementation loader” erschien. Nach einem Neustart des Systems arbeitete LanguageTool richtig, dass heißt Grammatik-Fehler wurden blau markiert.

Danke an dnaber!

Gruß Michael


(Michael G.) #25

Zu Post: Oct 04, 2012; 5:08pm

PC mit Betriebssytem Win Vista 32 Bit
Java 7 Update 9
OpenOffice.org 3.4.1

Nach dem Installieren von “vcredist_x86” ( http://www.microsoft.com/de-de/download/details.aspx?id=8328 ) und einem Neustart des PCs, konnte LanguageTool-1.9 ohne Fehlermeldung (“Could not create Java implementation loader”) installiert werden. Die Grammatik-Prüfung funktioniert seither.


(Michael G.) #26

Wenn jemand, der LanguageTool installieren möchte, dabei die folgende Fehlermeldung erhält: “Could not create Java implementation loader”, dann würde ich auf jeden Fall nachsehen, ob “Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)” installiert ist. Sollte es nicht installiert sein, so rate ich dies zuerst zu installieren, und dann noch mal zu versuchen LanguageTool zu installieren.

Unter http://www.microsoft.com/de-de/download/details.aspx?id=8328 das exe-File “vcredist_x86.exe” downloaden und installieren.

Diese Vorgehensweise hat bei mir bei zwei verschiedenen Systemen Erfolg gebracht (Win 7, 64 bit und Win Vista 32 bit).

Falls jemand damit Erfolg haben sollte, oder sonst etwas zu diesem Thema beitragen könnte, der soll es bitte hier im Thread machen.


(Janusch R.) #27

Hallo!

Ich möchte eine Beobachtung beitragen, die vielleicht die Lösung näher bringen könnte. Ich betreibe ein Win7 System 64 bit mit OpenOffice.org 3.4.1 und Language Tool 2.0. Seit ein paar Tagen habe ich mich geärgert, weil die R-Prüfung nicht läuft. Versuchte Neuinstallation sagte: “Could not create Java implementation loader”.

Seit einigen Tagen meckert Windows, dass ein Java Zertifikat nicht in Ordnung ist. Meistens klicke ich genervt diese Meldung mit NEIN weg. Heute habe ich aber JA angeklickt (Zertifikat zugelassen/vertrauen). Und plötzlich läuft LT wieder.

Ich vermute, dass die meisten Benutzer hier die Sicherheit so hoch eingestellt haben, dass nicht eindeutige Zertifikate automatisch abgeleht werden. Damit bekommt man nicht alle Rechte in Windows für Java und das jedes mal. Wird das eine Zertifikat abgelehnt und schwup tie wup: “Could not create Java implementation loader”.

Ist aber nur meine persönliche Deutung der Beobachtung. Vielleicht prüft das jemand enrsthaft, der sich mit Zertifikaten und co. bei Win auskennt.

Gruß
Janusch


(Daniel Naber) #28

On Di 05.02.2013, 14:17:41 you wrote:

Ist aber nur meine persönliche Deutung der Beobachtung. Vielleicht prüft
das jemand enrsthaft, der sich mit Zertifikaten und co. bei Win
auskennt.

Danke für den Hinweis - kannst Du vielleicht noch einen Screenshot von der
Meldung machen? Ich wüsste nämlich jetzt nicht, welches Zertifikat bei der
OpenOffice-Version überhaupt zum Einsatz kommt.

viele Grüße

Daniel


http://www.danielnaber.de