Back to LanguageTool Homepage - Privacy - Imprint

Language Tool vs Java 8


(eses) #1

Hello,

Since I have installed Java 8 (update 25), Language Tool stopped working on my Windows 7 machine. It displays the message that "Could not create Java implementation loader".

Is there anything I can do to resolve the issue except:
1. Downgrading to Java 7;
2. Waiting for update of Language Tool to work with Java 8?

Thank you for help and keep up the good work!
Slawek


(Daniel Naber) #2

Does your problem occur in the context of LibreOffice/OpenOffice? Is "Could not create Java implementation loader" the complete error message or is there more? LT usually works fine with Java 8, I have just tested it. You might also want to check our list of issues at https://languagetool.org/issues/


(Matias) #3

I get a very similar error when trying to install. The full error on my machine is:

"To view this web content, you need to install the Java Runtime Environment.
Click "More info..." to visit the website for the Java Runtime Environment."

Unfortunately I already have the latest version of Java running on my computer!!

LOversion: 4.3.2.2
Java version: 8 update 25
Mac OS X Yosemite (10.10)


(Matias) #4

To update my above post:

When I quit LO and then restarted it. I got an error regarding LT:

"LibreOffice requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice."

When I opened the extensions manager I also got this error, mirroring the original post:

"Could not create Java implementation loader"

I hope this helps!!


(Daniel Naber) #5

Matias, have you checked the points at https://languagetool.org/issues/?


(Matias) #6

Just installed Java for OS X from: http://support.apple.com/kb/dl1572
And I now get this fun error message:

(com.sun.star.uno.RuntimeException) { { Message = "[jni_uno bridge error] UNO calling Java method writeRegistryInfo: non-UNO exception occurred: java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 51.0\X000ajava stack trace:\X000ajava.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 51.0\X000a\X0009at java.lang.ClassLoader.defineClass1(Native Method)\X000a\X0009at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)\X000a\X0009at java.lang.ClassLoader.defineClass(ClassLoader.java:621)\X000a\X0009at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)\X000a\X0009at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)\X000a\X0009at java.net.URLClassLoader.access$000(URLClassLoader.java:58)\X000a\X0009at java.net.URLClassLoader$1.run(URLClassLoader.java:197)\X000a\X0009at java.security.AccessController.doPrivileged(Native Method)\X000a\X0009at java.net.URLClassLoader.findClass(URLClassLoader.java:190)\X000a\X0009at java.lang.ClassLoader.loadClass(ClassLoader.java:306)\X000a\X0009at java.lang.ClassLoader.loadClass(ClassLoader.java:295)\X000a\X0009at java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:627)\X000a\X0009at java.lang.ClassLoader.loadClass(ClassLoader.java:247)\X000a\X0009at com.sun.star.comp.loader.RegistrationClassFinder.find(RegistrationClassFinder.java:52)\X000a\X0009at com.sun.star.comp.loader.JavaLoader.writeRegistryInfo(JavaLoader.java:399)\X000a", Context = (com.sun.star.uno.XInterface) @0 } }


(Daniel Naber) #7

You need Java 7 or later, the version you've installed (or activated in LibreOffice) is an earlier one.


(eses) #8

Hello,

The issue started appearing in Libre Office version 4.3.2.2, after I have upgraded Java to 8.25, previously the installation worked fine. I have removed LT and tried to install again - the error appears while installation process. After I click OK (that "Could not create Java implementation loader" is the whole message), the extension appears in Libre Office with "unknown status" adnotation.

Just to be sure, I'm on Windows 7 :smile:

I'll try to reinstall Libre Office and LT, will notify you about the results.


(eses) #9

Hello,

Just to report: I have uninstalled Language Tool and removed everything from uno_packages. I have uninstalled LibreOffice 4.3.2.2 and installed it again using the downloader from their website. Then tried to install Language Tool...

Got "Could not create Java implementation loader" while installation.

So it seems that Java 8.25 causes the error...?


(joseluis) #10

I have java version "1.8.0_60"
Ubuntu 14.03 64bits
I had the same issue and install libreoffice-java-common from the repository.
And it worked like a charm.