Back to LanguageTool Homepage - Privacy - Imprint

LanguageTool does not auto check


#1

Tested with the LanguageTool Test Document.

System info:

  • OS: Windows 7 Service Pack 1 (64-bit)
  • LibreOffice: 6.1.1.2 (x64)
  • LanguageTool: 4.2 (2018-06-26 12:00)
  • Extension: Installed for current user

Checks done:

  • SET JAVA_HOME=C:\Program Files\Java\jdk1.8.0_102

  • PATH=C:\ProgramData\Oracle\Java\javapath; [...] ;C:\Program Files\Java\jdk1.8.0_102\bin; [...]

  • java -version:

      java version "1.8.0_102"
      Java(TM) SE Runtime Environment (build 1.8.0_102-b14)
      Java HotSpot(TM) 64-Bit Server VM (build 25.102-b14, mixed mode)   
    
  • Automatic Spell Checking: enabled (checked)

  • Tools > Options > Language Settings > Writing Aids > Lightproof grammar checker (English): disabled (unchecked)

  • Tools > Options > Language Settings > Writing Aids > Hunspell SpellChecker: enabled

  • Tools > Options > Language Settings > Writing Aids > LanguageTool: enabled

  • LanguageTool > Options > General > Your mother tongue: English

  • LanguageTool > Options > General > Check only the sentence containing paragraph (fastest): selected

Observations:

  • LightProof Grammar Checker is working. Once I check it to enable it, there is a blue squiggly line under “an test”.
  • If I disable LightProof Grammar Checker, the blue line disappears.
  • If I enable LanguageTool only, both test sentences are not checked or marked with blue squiggly lines indicating grammar error.
  • All the text in the test document is marked as English (USA).
  • No error message reported by LibreOffice or LanguageTool extension.
  • LanguageTool > About and Options open up without problem or error

#2

Update: LanguageTool 4.2 is working after I re-toggled the writing aids. It didn’t work previously even when I closed LibreOffice and rebooted my machine after toggling these writing aids on and off.

Under Tools > Options > Language Settings > Writing Aids:

  • Re-disabled Lightproof grammar checker (English)
  • Re-enabled LanguageTool
  • Re-enabled Libhyphen Hyphenator
  • Re-enabled Mythes Thesaurus

Pressed OK and suddenly it goes through a few seconds spinning busy rotating cursor and the LanguageTool appears to work.

Somehow it suddenly started working, and I do not know why and how to ensure it will always work.