LanguageTool for Desktop - Major bug


I can’t really find a proper place to report bugs, other than maybe GitHub, which I am not using at the moment. Please let me know in case this was better posted/sent elsewhere.

This bug is specifically in relation to the LanguageTool for Desktop – i.e. the new beta tool for grammar/spelling check in Outlook and Notepad.

I installed the tool early in January for the first time. I was actively using the App for about 2 weeks with no significant issues. There was an occasional bug, but that is fine for a beta.

I am not sure about the exact date, but I believe the App suddenly stopped working around 27th of January.

What do I mean by stopped working?

  • The app is visible as a running app in the Windows Task Manager, even the memory usage is going up and down during the day, it is not frozen or unresponsive
  • There is no User interface visible after the launch – no task bar icon, no app window, no Outlook interface. Same as if the App was not running, despite the fact, as mentioned above, it is clearly running.

What did I try to make it work (and failed)?

  • Run the app as an administrator
  • Uninstall, reinstall
  • uninstall, download the latest version, install (tried, and
  • uninstall, clean up regedit using search, clean up any leftover files in hidden system folders, reinstall
  • search for any debug or log files which could provide helpful info in app folders – nothing useful found other than compilation debugging from the developer’s device

My system:

  • i5-11400H
  • Windows 11 Home 22H2 Build 22621.1105
  • no new software installed around the time when the app stopped working

I like the tool, a lot. I just wish it worked again.