Back to LanguageTool Homepage - Privacy - Imprint

LanguageTool for Safari?

One more for testing.
I tried to compile the plugin in Xcode but it does not allow e to login to use the paid version.
But it seemed to work.

1 Like

Me tooo!!

Yes please! Safari or macOs support will be great.

+1 !!!

Any news on this??? Safari is one of the most used browsers by Mac people. Please consider adding it.

1 Like

Safari 14 (with Web Extensions support) is just released.
Any news @dnaber?

I can’t wait to switch form Chrome to Safari :slight_smile:

1 Like

We’re working on it, I can’t give a date yet.

6 Likes

Thanks

Yeah, I love the Safari Extension. But I even love the idea of having a macOS addin/tool even more :slight_smile:

2 Likes

Any news @dnaber? It would be great to start new year with new browser with LanguageTool add-on :slight_smile:

Maybe someone has the self compile version made in xcode and share them here?

2 Likes

Any status update here? Any chance to help you - maybe in doing some alpha/beta testing?

1 Like

Our browser add-on is now also available for Safari at https://apps.apple.com/app/languagetool-for-safari/id1534275760. It’s the first release, so please post feedback if you find any issues.

2 Likes

Great! :slight_smile:
Everything works fine except using my local languagetool server on docker (URL: http://localhost:8010/v2) :frowning:

Safari add-on says that can’t connect when Chrome in other window works fine with same settings.

BTW. You can also add info about other supported languages in App Store (now, there is only English and German).

Could you post the command you use to start your local server?

My local server works fine in Chrome - don’t work in Safari.

I use command:
docker run --rm -p 8010:8010 silviof/docker-languagetool

Could you check whether Docker is the cause of the problem by running LT directly?

java -cp languagetool-server.jar org.languagetool.server.HTTPServer --port 8010 --public --allow-origin '*'

Also, does it work if you specify https://api11.languagetool.org/v2 as the server in the settings?

I can’t check this now (installing java etc.). If I specify https://api11.languagetool.org/v2 in settings all works great.

EDIT: My bet - maybe Safari needs secure (https://) connection? Even if it’s local.

Yes, I think lack of HTTPS is what’s causing the issue.

I got it to work after setting a reverse proxy (Caddy, using these instructions https://auth0.com/docs/libraries/secure-local-development#how-to-set-up-a-secure-local-server) and changing the extension’s setting to use “Other server” (and setting it to https://localhost:8082/v2).

I wish Safari made it easier to find the issue.

How to open internal editor in Safari tab?
Something like URL chrome-extension://oldceeleldhonbafppcapldpdifcinji/validator/validator.html in Chrome?

I found URL safari-extension://{some ID}/{some ID}/validator/validator.html, but it’s not working. I can type text, but it is not checked by LanguageTool.

IIRC, there’s no item for LT in the context menu in Safari, is it? Thus, this feature isn’t accessible and has never been tested, I guess.