Back to LanguageTool Homepage - Privacy - Imprint

LanguageTool is cutting off text under certain conditions

(Thomas) #1

After a first path correction of a long ebook script, I found a fatal error on LanguageTool, which actualy prevents me from using it at the current state.
I am using LibreOffice and OpenOffice on a Mac with the latest versions. Both offie sutes show the same error.

Example: Wrongly placed ‘»’ in front of a sentence.
LanguageTool finds it and pops up a dialog.
Delete the » in the LanguageTool dialog to correct the error and click “change/ändern”.
Surprisingly, the error is not being corrected in the text.
As only active button remains »ignore«. If you click it – the entire sentence is deleted in the script.

Prior correction:
»Ich glaubte nicht, für dieses Tool bereit zu sein, obwohl es bei der Korrektur sehr hilfreich wäre.

Result after running LanguageTool over it.:

This happens under certain circumstance also with other text structures, such as sentences with multiple koma, or if you have a mix of several mistakes/typos you correct in one dialog. You really need to look after this and fix it. I can’t use Language tool with this error - but i really would like to have a tool like this that works and does not mess up my scripts.

(Daniel Naber) #2

I have just reproduced this. This is a bug in LibreOffice/OpenOffice:
when you remove the quote character and click the “Correct” button,
LanguageTool is not called at all. The correct behavior would be that
LanguageTool is called again, sees that the error has been fixed, and
LibreOffice jumps to the next error.

This is maybe somehow related to the quote being a special character.
For example, it works fine for me with this example:

und ein Satz, der klein anfängt.

Der Haus.

If I manually replace the “und” with “Und”, LibreOffice jumps to the
next error. The same happens if I use the correction that’s offered
(which is also “Und”, but we don’t offer suggestions for the quote

It would be nice if you could open a bug report at LibreOffice with the
information we have collected so far and post the link to the bug report
here. As a workaround, you could turn on on-the-fly checking that
underlines errors instead of using the check dialog.

(Thomas) #3

Thank you much for your quick reply.
I will try my best to send this error report to the OpenOffice and LibreOffice team if I can find out how …
If disabeling the dialog helps as a workaround, this would be great and i surely will try this.
Thank you.