Back to LanguageTool Homepage - Privacy - Imprint

LanuageTool in LibreOffice has never worked for me


(Mark Oliver) #1

My working environments for LanguageTool 3.8 are 64-bit Windows 7 Pro SP1 with Java Version 8 Update 144 and LibreOffice 5.3.4
… and …
64-bit Linux Mint 18.2 with openjdk-8-jre and LibreOffice 5.1.6.

I have never in years of trying been able to get LanguageTool working in LibreOffice. To test my installation, I navigated to https://languagetool.org/ and copied the sample text on display there and pasted it into LibreOffice text documents. I highlighted the text and opened the menu item Tools > LanguageTools > Check Text. Nothing happens but a plain-vanilla LibreOffice spell check. The grammar issues called out on your website are not highlighted in LibreOffice. I get the same absence of results in both Windows and Linux. In short, I have no evidence that the extension is functioning at all.

Since I have no screen shots, I don’t even know what it is supposed to look like when it does its job.

My wife desperately wants a grammar checker and is angry with me for not providing her one, and I am at a loss. [I see that the Firefox extension deals with the indicated errors in your sample text, but I don’t have so much as a picture of what is supposed to happen in LibreOffice.]

What am I doing wrong?


(Daniel Naber) #2

This is how it looks like for me, i.e. you get blue underlines additionally to red ones:

Have you checked the items listed at https://languagetool.org/issues/?


(Tiago F. Santos) #3

Try this:

LibreOffice comes with its own integrated grammar checker (LightProof) which disables LanguageTool for English and Russian. Use Options -> Language Settings -> Writing aids -> Edit... to disable LightProof and enable LanguageTool for the language you are working with to make LanguageTool work.

from the link that Daniel provided.
I am also on Mint 18.2 and this is the only thing you have to do.


(Mark Oliver) #4

Thank you both for your speedy replies; I am not accustomed to such good service.

In Windows and Linux I disabled LightProof and went to Tools > Options > Language Settings > Writing Aids > EDIT… to enable LanguageTool for English. LanguageTool is functioning in both operating systems now.

I did not see the notice “Please see our checklist if you experience problems.” because, frankly, I cannot read a font that small. I would suggest making that line larger. Better yet, at the top of https://languagetool.org/ after “Development” you could add “Support” and link to the issues page there. That would have saved me from bothering you on the forum. Again, many thanks.

P.S. I tested the phrase, “Those two is very nice.”, but this phrase is not marked up. I hope someone with a knowledge of rule writing will look into this. I also hope that sometime soon LanguageTool will work with LibreOffice documents containing revisions; this seems like a pretty big deal. (It appears that no one at LO cares.)


(Mike Unwalla) #5

Fixed (https://github.com/languagetool-org/languagetool/commit/f74f1a4c6437299156483caf0c8f7f4426319865). The correction will be in tonight's snapshot.