Back to LanguageTool Homepage - Privacy - Imprint

LibreOffice extension crash

I have LibreOffice with LanguageTool extension.

I get an error of multiple sentences starting with the same word.

Since this is the intended phrasing, I’m right clicking on the error and select “Ignore”.

When I do so, LanguageTool crash:

LibreOffice version info:
Version: 7.3.5.2 / LibreOffice Community
Build ID: 184fe81b8c8c30d8b5082578aee2fed2ea847c01
CPU threads: 12; OS: Linux 5.18; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

LanguageTool: 5.8

This bug should be solved. Please test tomorrow’s snapshot 20220809 at Index of /snapshots/

1 Like

Sorry, but now it is not even detected as an error, and “Check Text (F7)” (the magnifying glass) is extremely slow and painful.

It also crashed again. See here (this website is truncating the image if I attach it here).

The reported bug is solved. Please test it with the tomorrow nightly.
The start of the dialog is sometimes slow, especially, when a huge document is just opened. LT generates a cache in the background. The check dialog should speed up with the time a document is opened.

Do you mean this bug?

With LibreOffice 7.4 and LT 5.8, I also get this error message. The snapshot build worked for me.

Are there any plans to backport the fix to LT 5.8.1 as an interim release?

LibreOffice 7.4 now supports connecting to a LanguageTool server natively. I suggest you run a local server and connect to it, without any need for an extension.

Thanks for your response. However, I am just a user of LibreOffice Writer who wants grammar to be checked. The easiest is the extension. I am not familiar with setting up an own local server just to check grammar. On the first sight, it sounds more complicated than clicking on an .oxt file…