LibreOffice UI blocked on big documents

Often I open very big documents - ~1500-2500 pages (e.g. for multivolume book or a dictionary) and if automatic spellcheck with LT is on the whole UI is blocked for several minutes (I have i5-13600K CPU).

  1. I am not sure if it’s a LT or problem
  2. ‘Paragraph Check Mode’ is selected (not ‘Text Check Mode’)
  3. My CPU has 20 cores and only 1 is busy while UI is blocked (I suspect it’s not easy to parallelize?)
  4. I am running with locally built oxt 6.4-SNAPSHOT

To run LT at more than one core: Open LT-Options / Technical settings. You can choose ‘Use more than one core’.

By the way, I also recommend text mode for large files. A cache is used. It costs more memory but increases performance. It is also saved between different sessions.

I think I saw a recommendation to use ‘paragraph-level’ for better performance, but I’ve switched to text-level to try.
I’ve just checked and ‘Use more than one core’ is on, and I still see only 1 core used.
Checking a doc with 2550 pages took ~45 s (that’s probably spellcheck +LT).