Back to LanguageTool Homepage - Privacy - Imprint

LT addon for Google Drive is failing

Lately I see that the LanguageTool addon for Google drive is failing to connect
drive.google.com refused to connect.

@dnaber any ideas of what is going on?

Could you post a screenshot of the error you get?

@dnaber here you go:

I can’t reproduce that, but I’ll ask the developer. As a quick workaround, you might want to try our browser add-on (https://languagetool.org/#firefox_chrome), which also works with Google Docs now.

@dnaber I’m using the browser plugin, but I like the docs addon more for a full check ! :stuck_out_tongue:

Also I’ve checked the Console after loading the docs addon and it says:
Refused to display in a frame because it set ‘X-Frame-Options’ to ‘sameorigin’.

Also I’ve tryed to test it in Firefox and it works fine.

So your original issue was in Chrome? Which version of Chrome was that?

@dnaber latest
image

Chrome has been warning about an upcoming update to its security policies, maybe it has finally landed.

Maybe related to this: https://blog.chromium.org/2020/04/temporarily-rolling-back-samesite.html

Haven’t found the issue ?

No, your report was the only one so far, and we can’t reproduce it. It might be specific to your setup. Maybe a different add-on, security software or something like that.

I think I’ve found the issue. I has something to do with accounts.

I did uninstall Chrome and reinstall it to see what is going on. Disabled all extensions but nothing it did not work.

But suddenly I discovered a weird behaviour I explain:

I have 3 Google Accounts
Account A: main
Account B
Account C

With a fresh install of Google Chrome in connect and sync Account A
I go to the Google Doc and start the LanguageTool addon: It works right

Then I switch to Account B: same procedure: It works right

Then I go to Account C: and it fails
Note that Account C is the owner of the document.

I’ve tested creating a document with account B and sharing with A and C: Same issue: C has the same error. So is something related to Account C, nothing to do with Chrome or with the other Addons…

Now I’ve uninstalled the LanguageTool from Account C and tried to reinstall… but it simply don’t reinstall. It seems like the installation is binded to Account A exclusively.

Extra testing (I’m writting this as I test):
I’ve logged in with a 4th account, lets say Account D, and it happens the same than with Account.
What has Account B different than C and D? It’s a Google Suite account.

Also I’ve tried opening with Account C and D the extension Code Blocks and it also shows the same error as in Language Tool… It seems that a new Google Chrome policy is blocking other accounts?

Final test:
I’ve tried in a second computer with two Accounts E and F and happens the same
I log in with Account E, install LanguageTool everything fine
Then I log in with Account F in the same document, install LanguageTool and issues start to arise.

So the problem is related with a multiple account issue.

@dnaber additional info:
I’ve tried this also with Firefox and happens the same:
The key is to login in a document with an Google account that is not the default one: