Back to LanguageTool Homepage - Privacy - Imprint

LT no longer takes language setting into account in OO


(Lodewijk Arie van Brienen) #1

on 4.4 and before opening the LT options window called up the language module based on the active paragraph’s language.
This seems to be no longer the case, making it even harder to deal with problematic rules when working on a multi-language document.


(Daniel Naber) #2

@Fred.Kruse I can confirm - is this something you could fix?


(Fred Kruse) #3

In 4.5 I did some changes to handle the language in the Option window. Could you please check if the problem exist in 4.5 too?


(Daniel Naber) #4

I think the point was that is started with 4.5 and was okay until 4.4.


(Daniel Naber) #5

When I revert this change, the issue is fixed: https://github.com/languagetool-org/languagetool/commit/deec4044f29765da1a8a2e6a5576a81f34fe7460#diff-e6393298f52f9494c28fd8a775736003 - however, I don’t know what exactly that implies and whether it would introduce new issues.


(Fred Kruse) #6

I just fixed the issue.


(Daniel Naber) #7

Version 4.5.1 has just been released, it should fix this issue.


(Lodewijk Arie van Brienen) #8

4.5.1 constantly reverts to factory settings, no choice but to revert to 4.4 and manually restore all settings.


(Daniel Naber) #9

I cannot reproduce that - what is your exact workflow that causes this?


(Lodewijk Arie van Brienen) #10

I’ve done some further tests and it seems that the act of calling up the settings window while LT is refreshing after a rule-change causes it to fail to load the user settings … you can cancel in that case, but pressing OK will cause it to save the factory setting over the user settings. (The new rules in 4.5 had me haste a bit too much in setting them correctly, so I think it best if this issue is fixed ASAP)

and IMHO 4.5 didn’t really add that many rules that were worth the hassle.