Back to LanguageTool Homepage - Privacy - Imprint

LT plugin 5.7 no function with LibreOffice 7.3.3.2 on Ubuntu 22.04 LTS

Hello everybody!
I installed the Language Tool 5.7 plugin in my LibreOffice 7.3.3.2.
Unfortunately none of the Language Tool functions work. Neither options nor others. No reaction. Below is all the information about my installation.

Ubuntu Information:
LSB Version: core-11.1.0ubuntu4-noarch:printing-11.1.0ubuntu4-noarch:security-11.1.0ubuntu4-noarch
Distributor ID: Ubuntu
Description: Ubuntu 22.04 LTS
Release: 22.04
Codename: jammy

LibreOffice Information:
LibreOffice 7.3.3.2 30(Build:2)

Java Information:
openjdk 11.0.15 2022-04-19
OpenJDK Runtime Environment (build 11.0.15+10-Ubuntu-0ubuntu0.22.04.1)
OpenJDK 64-Bit Server VM (build 11.0.15+10-Ubuntu-0ubuntu0.22.04.1, mixed mode)

Language Tool Plugin Version 5.7

1 Like

To exclude a possible cause of error: Did you also install the package libreoffice-java-common which is required under Ubuntu?

:link: Linux-specific issues

Hi Mark,
Thank you for your answer.
Yes I checked all dependencies multiple times.

sudo apt install libreoffice-java-common
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
libreoffice-java-common ist schon die neueste Version (1:7.3.3-0ubuntu0.22.04.1).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 15 nicht aktualisiert.

libreoffice-java-common ist schon die neueste Version (1:7.3.3-0ubuntu0.22.04.1)

Good, this would exclude this possible cause of the error.

Did you also select the installed Java version in LibreOffice under Tools (Extras) > Options (Optionen) > LibreOffice > Advanced (Erweitert)?

[…] und 15 nicht aktualisiert.

Hm, your system is definitely not up to date. You should fix that as soon as possible and update your system by running the following command in the terminal.

sudo apt update && sudo apt full-upgrade

1 Like

OK the system is now up to date. A new kernel version was installed.
And the Java version is also set correctly. See image.

That’s nice. :smiley_cat:

But the most important question of all remains unanswered: Does the LanguageTool extension work now?

Nope :frowning:

Too bad. I’m sorry, but I don’t know what else could be the problem. As I’m just a simple user myself, where the extension works fine under Ubuntu 22.04 and macOS Catalina, the LanguageTool developers should now take a closer look at your issue.

One more thing comes to mind. This might sound stupid, but what you could do is to check if the automatic spell and grammar check is enabled and if the LanguageTool extension itself is enabled. That’s all I can think of at the moment.

After turning on the automatic spell checker, something seems to happen. However, the errors are underlined in red and not in blue. So it doesn’t seem to check LanguageTool but the standard spell checker.
When I let LanguageTool check the text, the result window is empty.

Hmm, that’s odd. Could you check the functionality of the extension with the LanguageTool test document?

:link: Installation Issues with LibreOffice/OpenOffice

Now I have set the LibreOffice Writer to English and LanguageTool too. The result is the same as with my German setting and German text. I also checked everything that was described in the documents. None of the error descriptions apply to my installation.

I think it’s a shame that there are so many complications.
My Ubuntu 22.04 LTS has only been installed for a few weeks, so it’s fresh and not somehow exotic. LibreOffice is installed by default. Well, you could live with a few dependencies like Java and libreoffice-java-common, although I wonder why it’s not included in the standard package.
Installing a plugin should also be a simple matter. In my Thunderbird, LanguageTool was just a few clicks away and worked right away.
I don’t understand why it all has to be so complicated.
I’m curious to see what else I can check or do so that my LanguageTool is finally up and running.
It might also be helpful if a developer took a look at my problem. I am happy to provide any log and configuration file.

Yes, I can understand your frustration. After installing a Java Runtime Environment (JRE) and the libreoffice-java-common package, the LanguageTool extension should actually work as desired. As I said, it works for me on Ubuntu and macOS. Why it doesn’t work on your installation, I can’t tell you. Especially since there are no error messages. My personal solutions are exhausted. I think it’s up to the LanguageTool developers now.

Thank you Mark for your extensive help. It looks like I’m a step further, but unfortunately I’m not there yet.

After playing around with the settings a bit, I got a message that LanguageTool is turned off. For whatever reason. After I clicked on the switch off/on option, I get a window for the first time in which I can correct something.
In summary, the two switches Automatic Spell Check and LanguageTool Off/On were missing.
Many thanks for your help.
So the case can be closed.
Many thanks for your help.

1 Like

This is fantastic news. Congratulations. Then you will finally be able to enjoy the capabilities of the LanguageTool extension. I’m glad I was able to help you and even provide the solution in the end.

Since you started this thread, you might as well mark it as solved yourself by marking post #8 as a solution.