LT stopped working – issue with profiles?

Hi there! I’ve noticed that LT hasn’t been working any more recently. It is activated but doesn’t highlight any linguistic issues.

Is it possible that is has issues with browser profiles?
I created several Brave profiles recently, and I installed and activated LT in all of these profiles. It doesn’t work in any of these though.

Greatful for any advice.
Thank you! :slight_smile:

Hi Tanja, we’re not aware of any such issues. The profiles don’t have private/incognito mode enabled, do they? Can you confirm whether it works with this simple test page? LanguageTool browser add-on test

Hi Daniel! And thanks for the superfast response!

No, no private or incognito mode enabled. It does work on the test page though, at least it marks the spelling related issue (“der Haus”, but not “er äußerst” by the way).

Do you have an example of a page where it doesn’t work? If it works on the test page, that sounds like the issue is not related to profiles.

Hmmm, I just checked: all the pages where I noticed it happening today are in a private setting (not in a private browser window but a password-protected environment), so I cannot share them, unfortunately.

Does LT stop working when texts are too long?

Yes, but it should still show up in the lower-right corner and give you feedback about the text being too long.

Let me observe that. What is the maximum length that is supported?

For free users, it’s ~ 10,000 characters.

It seems I have very similar problem on Firefox. Symptoms described by @tanja happen occasionally with Firefox upgrades, which is very annoying: add-on is turned on, I am logged in to my account, but there is not add-on menus etc. It is difficult to guess how to make it work. It happened the FF restart helped, but now it won’t. Enabling and disabling also does not help.

Do you also use profiles? If the add-on “LT” icon doesn’t appear in the browser’s toolbar, have you made sure it’s not just hidden behind the puzzle icon?


I do not use profiles. Though I use firefox containers. But so far it was not problem. And yes LT icon is hidden, but I can access it and click it on it and it shows that add-on is active.
But there is no spelling check within FF editor windows.

If this happens again, could you check whether the text checking also doesn’t work on LanguageTool browser add-on test? If it does work there, please let us know the page on which it doesn’t work. Also, please try whether turning off FF containers helps. We’re not aware of any issues with FF when using the standard configuration.

It is not working right now, on any page, also on mention by you “LanguageTool browser add-on test”. Unfortunately I can not turn off FF containers since I am heavily using them, and I am afraid that doing so can really mess up my work. Maybe there is some way to “reset” the extension so it removes all its data. I have already tried to disable and enable it but it have not helped. I am currently on FF version 117.0.1. Since I have just noticed that there is FF upgrade scheduled, I will upgrade and let you know.

Does uninstall and re-install help?

Well, how could I not think about it! That helped :slight_smile: Thanks a lot :slightly_smiling_face: All the best :slightly_smiling_face:

I’d like to add to this too! I have the same problem. Chrome, with 6 profiles.
When I first open Chrome all is well, after I have switched profiles a few times, LT stops visibly working. The extension is still running, the icon on text boxes and Gmail is still active, but nothing highlights in the content.

If this happens, does it also happen on a simple page like LanguageTool browser add-on test? If so, is there a specific way to reproduce this, e.g. by switching profiles, or does it seem to appear randomly?

I’ll let you know next time…