Back to LanguageTool Homepage - Privacy - Imprint

LT with TexStudio on MacOS


(LeCost) #1

Hi,

I am trying to run LT with TexStudio on MacOSX 10.8.2.
I have java 7 (not the oracle one). LT is running without a problem (I downloaded 2.4.1) and I can see that there is a connection with TexStudio.

COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
java 9707 ntinos 63u IPv6 0x889cd09f0a0c279d 0t0 TCP localhost:sunproxyadmin->localhost:59549 (ESTABLISHED)
java 9707 ntinos 67u IPv6 0x889cd09ef8fb1bfd 0t0 TCP localhost:sunproxyadmin (LISTEN)
texstudio 9716 ntinos 30u IPv6 0x889cd09ef717179d 0t0 TCP localhost:59547->localhost:sunproxyadmin (SYN_SENT)
texstudio 9716 ntinos 37u IPv4 0x889cd09f101d3f6d 0t0 TCP localhost:59549->localhost:sunproxyadmin (ESTABLISHED)

However, even if I type something "wrong" in TexStudio like "This is a example.", I do not see it underlined.

Does anyone else have similar problem?
Do I have to run the Oracle Java as specified here (https://languagetool.org/issues/) ? This is an issue with LibreOffice though and I do not see any error.


(FeMann) #2

I have the same problem, it seems texStudio does not "connect" to LT.

Any ideas how to solve this?

BTW, what command was that one you used to get the processes running?


(LeCost) #3

On the contrary, from what I have seen, texStudio has established the connection to LT.
Therefore, it might be a problem with texStudio MAC version.

For the connections the command is "lsof"
http://osxdaily.com/2011/07/11/display-a-list-of-open-network-connections-on-the-mac-os-x-desktop/


(FeMann) #4

Indeed,

thou i have tried, 2.66, 2.64 and 2.62 and all have the same problem.

I remember thou, that in the past (like 1 year ago) i used texStudio + LT in the Mac without problems (It worked in the past).

It could also be something with 10.9.1 . . .

Anyway, you are right, once launching texStudio, LT goes from:

java 20762 XXX 62u IPv6 0x6d1accc672e4188d 0t0 TCP localhost:cslistener (LISTEN)

to this:

java 20762 XXX 62u IPv6 0x6d1accc672e4188d 0t0 TCP localhost:cslistener (LISTEN)
java 20762 XXX 67u IPv6 0x6d1accc673e2fbcd 0t0 TCP localhost:cslistener->localhost:65204 (ESTABLISHED)
java 20762 XXX 68u IPv6 0x6d1accc66ec5554d 0t0 TCP localhost:cslistener->localhost:65205 (ESTABLISHED)
java 20762 XXX 69u IPv6 0x6d1accc6694e420d 0t0 TCP localhost:cslistener->localhost:65206 (ESTABLISHED)

More connections will open once i type words (wrong types/mistakes) in texStudio.


(LeCost) #5

I haven't upgraded to 10.9.1 yet, I am still with 10.8.5

It could be just a configuration of texStudio, to highlight the 'wrong', since it makes the connection, and I assume gets some answer.

--
Konstantinos Katsaros

On Wednesday, 29 January 2014 at 15:17, FeMann [via LanguageTool User Forum] wrote:

Indeed,

thou i have tried, 2.66, 2.64 and 2.62 and all have the same problem.

I remember thou, that in the past (like 1 year ago) i used texStudio + LT in the Mac without problems (It worked in the past).

It could also be something with 10.9.1 . . .

Anyway, you are right, once launching texStudio, LT goes from:

java 20762 XXX 62u IPv6 0x6d1accc672e4188d 0t0 TCP localhost:cslistener (LISTEN)

to this:

java 20762 XXX 62u IPv6 0x6d1accc672e4188d 0t0 TCP localhost:cslistener (LISTEN)
java 20762 XXX 67u IPv6 0x6d1accc673e2fbcd 0t0 TCP localhost:cslistener->localhost:65204 (ESTABLISHED)
java 20762 XXX 68u IPv6 0x6d1accc66ec5554d 0t0 TCP localhost:cslistener->localhost:65205 (ESTABLISHED)
java 20762 XXX 69u IPv6 0x6d1accc6694e420d 0t0 TCP localhost:cslistener->localhost:65206 (ESTABLISHED)

More connections will open once i type words (wrong types/mistakes) in texStudio.

If you reply to this email, your message will be added to the discussion below: http://languagetool-user-forum.2306527.n4.nabble.com/LT-with-TexStudio-on-MacOS-tp4641356p4641377.html
To unsubscribe from LT with TexStudio on MacOS, click here (http://languagetool-user-forum.2306527.n4.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=4641356&code=ZGlub3Mua2F0c2Fyb3NAZ21haWwuY29tfDQ2NDEzNTZ8LTE4MjU5ODMzNg==).
NAML (http://languagetool-user-forum.2306527.n4.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml)


(LeCost) #6

I checked that some errors are highlighted, other not.

For example in this line: "This is a example unput to to show you how ." the texShop highlights only the "to to" where as LT highlights "a", "unput", "to to" and " ." (extra space at end).

It does not make sense. I check the highlighting mode in texStudio on Mac and Win installations, they are the same. I manually enabled all grammar errors highlighting, still nothing.

--
Konstantinos Katsaros

On Wednesday, 29 January 2014 at 15:23, Konstantinos Katsaros wrote:

I haven't upgraded to 10.9.1 yet, I am still with 10.8.5

It could be just a configuration of texStudio, to highlight the 'wrong', since it makes the connection, and I assume gets some answer.

--
Konstantinos Katsaros

On Wednesday, 29 January 2014 at 15:17, FeMann [via LanguageTool User Forum] wrote:

Indeed,

thou i have tried, 2.66, 2.64 and 2.62 and all have the same problem.

I remember thou, that in the past (like 1 year ago) i used texStudio + LT in the Mac without problems (It worked in the past).

It could also be something with 10.9.1 . . .

Anyway, you are right, once launching texStudio, LT goes from:

java 20762 XXX 62u IPv6 0x6d1accc672e4188d 0t0 TCP localhost:cslistener (LISTEN)

to this:

java 20762 XXX 62u IPv6 0x6d1accc672e4188d 0t0 TCP localhost:cslistener (LISTEN)
java 20762 XXX 67u IPv6 0x6d1accc673e2fbcd 0t0 TCP localhost:cslistener->localhost:65204 (ESTABLISHED)
java 20762 XXX 68u IPv6 0x6d1accc66ec5554d 0t0 TCP localhost:cslistener->localhost:65205 (ESTABLISHED)
java 20762 XXX 69u IPv6 0x6d1accc6694e420d 0t0 TCP localhost:cslistener->localhost:65206 (ESTABLISHED)

More connections will open once i type words (wrong types/mistakes) in texStudio.

If you reply to this email, your message will be added to the discussion below: http://languagetool-user-forum.2306527.n4.nabble.com/LT-with-TexStudio-on-MacOS-tp4641356p4641377.html
To unsubscribe from LT with TexStudio on MacOS, click here (http://languagetool-user-forum.2306527.n4.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=4641356&code=ZGlub3Mua2F0c2Fyb3NAZ21haWwuY29tfDQ2NDEzNTZ8LTE4MjU5ODMzNg==).
NAML (http://languagetool-user-forum.2306527.n4.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml)


(Daniel Naber) #7

If LT is started in server mode, you can debug it with your browser by calling e.g. http://localhost:8081/?language=en&text=my+text. See http://wiki.languagetool.org/http-server for more about the HTTP API.


(LeCost) #8

What do you mean debug it? When I open the link you posted, I see the corresponding XML file and it looks like it's working fine.

--
Konstantinos Katsaros

On Wednesday, 29 January 2014 at 15:52, dnaber [via LanguageTool User Forum] wrote:

If LT is started in server mode, you can debug it with your browser by calling e.g. http://localhost:8081/?language=en&text=my+text. See http://wiki.languagetool.org/http-server for more about the HTTP API.

If you reply to this email, your message will be added to the discussion below: http://languagetool-user-forum.2306527.n4.nabble.com/LT-with-TexStudio-on-MacOS-tp4641356p4641382.html
To unsubscribe from LT with TexStudio on MacOS, click here (http://languagetool-user-forum.2306527.n4.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=4641356&code=ZGlub3Mua2F0c2Fyb3NAZ21haWwuY29tfDQ2NDEzNTZ8LTE4MjU5ODMzNg==).
NAML (http://languagetool-user-forum.2306527.n4.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml)


(FeMann) #9

For me it just comes an empty page (all white)

edit,

that is in Safari, in Chrome i get an xml data and it seems everything is fine.


(Daniel Naber) #10

By debug I mean that you can see if the problem is on the LT side, which doesn't seem to be the case if the XML looks good and lists all errors. If the page is blank - what browser did you use? Does the page source show the XML?


(FeMann) #11

The page was blank in Safari, but once i tried opening it in Chrome, the data was showed and all seemed fine with the response to the test code i sent to LT, the XML looked fine.

So, it must be an issue with texStudio.


(LeCost) #12

The issue is fixed for me after contacting the texStudio developer.

The problem was that the dictionary (thus language) was not loaded properly.

The default path that was selected was /Volumes/texstudio/texstudio.app/Contents/Resources which was wrong.
The correct path is /Applications/texstudio.app/Contents/Resources (at least for my installation)

Now I can select the language and LT can find the errors.


(FeMann) #13

Are you sure that the errors being found/shown are being reported by LT?

Because, for me, the path is correct, and i get errors being marked, but by the suggestions of texStudio DB and not by suggestions from LT.

An example:

Aggregation is pointed as an error in texStudio (maybe because the word isn't in texStudio DB/Directory), but the same word is seen as correct in LT, therefor, it shouldn't be marked as an error in texStudio.


(LeCost) #14

Yes, it is from LT.
I checked this simple text: "This is a example" and without LT, "a" is not underlined. With LT, it gives an error to use "an".

--
Konstantinos Katsaros

On Sunday, 2 February 2014 at 15:58, FeMann [via LanguageTool User Forum] wrote:

Are you sure that the errors being found/shown are being reported by LT?

Because, for me, the path is correct, and i get errors being marked, but by the suggestions of texStudio DB and not by suggestions from LT.

If you reply to this email, your message will be added to the discussion below: http://languagetool-user-forum.2306527.n4.nabble.com/LT-with-TexStudio-on-MacOS-tp4641356p4641395.html
To unsubscribe from LT with TexStudio on MacOS, click here (http://languagetool-user-forum.2306527.n4.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=4641356&code=ZGlub3Mua2F0c2Fyb3NAZ21haWwuY29tfDQ2NDEzNTZ8LTE4MjU5ODMzNg==).
NAML (http://languagetool-user-forum.2306527.n4.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml)


(Radan Suba) #15

Hello, I am having the same trouble. I've set the path properly as you indicated in one of the post, but it helped only partially. Now, I get grammar check from TexStudio but no LT. I cannot see any LT underlining for famous "this is a example" quote. Any suggestions?