Back to LanguageTool Homepage - Privacy - Imprint

Mac issue


(William Wittmeyer) #1

I got the following message when attempting to enable LT 2.3 on a MacBook Air running OS 10.9.3 Avast version 8.0 was running

jni_uno bridge error] UNO calling Java method writeRegistryInfo: non-UNO exception occurred: java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 51.0
java stack trace:
java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:295)
at java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:627)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at com.sun.star.comp.loader.RegistrationClassFinder.find(RegistrationClassFinder.java:55)
at com.sun.star.comp.loader.JavaLoader.writeRegistryInfo(JavaLoader.java:399)


(Daniel Naber) #2

You're still using Java 6, but LanguageTool requires Java 7. Note that Java 7 does not only need to be installed but also activated in LibreOffice (Tools -> Options -> Advanced) or OpenOffice.org (Tools -> Options -> Java).


(William Wittmeyer) #3

Thank you