Back to LanguageTool Homepage - Privacy - Imprint

New webserver on languagetool.org - any issues?


(Daniel Naber) #1

Hi, we have switched from Apache to nginx as the webserver for languagetool.org. If everything works well, nobody should notice any difference. If you experience any issues, please let me know.


(Lodewijk Arie van Brienen) #2

Only a caching issue, but a hard-refresh solved that.


(Daniel Naber) #3

Even that should not happen - what exactly was the issue?


#4

Keep getting the following error in google docs extension:

Error: Cannot connect to the server https://languagetoolplus.com/api/v2/, Exception: Request failed for https://languagetoolplus.com/api/v2/check returned code 500.


#5

Truncated server response: Error: Internal Error: Could not get token for user xxx
from https://languagetoolplus.com/token, inva… (use muteHttpExceptions option to examine full response)


(Lodewijk Arie van Brienen) #6

Some of the visuals were a bit glitched, but that could simply have been an issue that coincided with my first refresh of the main page (I keep both the main page and the main forum page open 24/7 for easy access) after first reading this topic.


(Daniel Naber) #7

I cannot reproduce this - are you sure it worked before? Can you log in at languagetoolplus.com with the username and password you have set in the options of the add-on?


#8

Yes, I’m sure - it was working fine until today. I am logged in, and i’ve checked - yes I can login at [languagetoolplus


(Daniel Naber) #9

Please send me your email address via private message so I can analyze the issue.