Back to LanguageTool Homepage - Privacy - Imprint

Problems setting up LT with Texstudio


(Thomas Kühner) #1

Hello,
I have this error when using LT together with Tex Studio. I tried setting the classpath but without success.
I am using Linux mint 17.2, Java 8 and TexStudio 2.6.6
Any idea what I need to do or what might be the issue. Google didn't help me unfortunately. Thx a lot.
Stacktrace from the server:

***2016-05-12 15:52:53 An error has occurred. Access from 127.0.0.1, text length 28. Stacktrace follows:**
java.lang.IllegalArgumentException: '' is not a language code known to LanguageTool. Supported language codes are: ast-ES, be-BY, br-FR, ca-ES, ca-ES-valencia, da-DK, de, de-AT, de-CH, de-DE, de-DE-x-simple-language, el-GR, en, en-AU, en-CA, en-GB, en-NZ, en-US, en-ZA, eo, es, fa, fr, gl-ES, is-IS, it, ja-JP, km-KH, lt-LT, ml-IN, nl, pl-PL, pt, pt-BR, pt-PT, ro-RO, ru-RU, sk-SK, sl-SI, sv, ta-IN, tl-PH, uk-UA, zh-CN. The list of languages is read from META-INF/org/languagetool/language-module.properties in the Java classpath. See http://wiki.languagetool.org/java-api for details.
** at org.languagetool.Languages.getLanguageForShortName(Languages.java:153)**
** at org.languagetool.server.LanguageToolHttpHandler.getLanguage(LanguageToolHttpHandler.java:488)**
** at org.languagetool.server.LanguageToolHttpHandler.checkText(LanguageToolHttpHandler.java:382)**
** at org.languagetool.server.LanguageToolHttpHandler.handle(LanguageToolHttpHandler.java:209)**
** at com.sun.net.httpserver.Filter$Chain.doFilter(Filter.java:79)**
** at sun.net.httpserver.AuthFilter.doFilter(AuthFilter.java:83)**
** at com.sun.net.httpserver.Filter$Chain.doFilter(Filter.java:82)**
** at sun.net.httpserver.ServerImpl$Exchange$LinkHandler.handle(ServerImpl.java:675)**
** at com.sun.net.httpserver.Filter$Chain.doFilter(Filter.java:79)**
** at sun.net.httpserver.ServerImpl$Exchange.run(ServerImpl.java:647)**
** at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)**
** at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)**
** at java.lang.Thread.run(Thread.java:745)**


(Daniel Naber) #2

Hi Thomas, for some reason the language parameter is missing. Do you have set a language for your text? Maybe you're lucky and someone has an idea, but it's probably something the Texstudio developers can better help with.


(Thomas Kühner) #3

Thx for your reply. I have already checked that. My language is set to english in Texstudio.


(Thomas Kühner) #4

Ok, I could solve it. The problem was, I used version 2.6.6 from package manager. Using version 2.10 from texstuido.org solved this issue.