Back to LanguageTool Homepage - Privacy - Imprint

Server changed?


(Ruud Baars) #1

For a long time I used the locally running server:
java -cp $LTDIR/languagetool-server.jar org.languagetool.server.HTTPServer --port 8081 -t

Somehow, this does not start any longer.

This does not help either (The page is not where the link directs to):
languagetool-server.jar org.languagetool.server.HTTPServer --port 8081 -t
WARNING: unknown option: org.languagetool.server.HTTPServer
WARNING: unknown option: -t
Parameter --config must be set and point to a property file
Note: this is the HTTPS server - if you want to use plain HTTP instead, please see http://languagetool.org/http-server/


(Daniel Naber) #2

I don’t remember the -t option - LT has, I think, become stricter about accpeting nonexisting options. So I think the behaviour is correct, just remove the -t and it should work again.


(Ruud Baars) #3

java -cp $LTDIR/languagetool-server.jar org.languagetool.server.HTTPServer --port 8081
Error: Could not find or load main class org.languagetool.server.HTTPServer

What is the correct way to do it?


(Daniel Naber) #4

Run your command from the directory that contains languagetool-server.jar.


(Ruud Baars) #5

That is rather inconvenient. And it worked until today… But anyway, I will work around it. Just quite surprised…


(Daniel Naber) #6

Are you sure $LTDIR is set and points to the right location? I don’t think there has been any change in LT that could cause this.


(Ruud Baars) #7

Yes, I am sure. Maybe something else changed on my system; I would not know what, however. Anyway, I worked around it, using minimized LT gui as a server now.