Spell and Grammar check in Thunderbird reply mails


when I reply to an email with quoting the original message the Languagetool add-on does not recognize the text. The tool says:
Text is too short. Please enter at least 5 characters…
No matter how much text I write it does not recognize my part of the message. If I delete the quoted text, the check is then available and the add-on works.
Can you help me find a solution to this, other than deleting the quoted text?

Thank you!

Do you use a signature? Do you maybe type your text into the signature area (which is ignored by LT)? If that doesn’t help, could you maybe send a screenshot that shows the problem?

Hi Daniel,

I don’t use a signature.
Here is a screenshot of the described issue.

Thank you!

Thanks. That’s interesting, I cannot reproduce that yet. Which version of Thunderbird do you use? Do you use other TB add-on at the same time? If so, does turning them off temporarily help?


I am running Thunderbird 102.7.0 (64-bit) on Mac OS Ventura 13.0 (22A380).
I disabled all other add-ons and still have the same issue. Also the Picky mode is disabled.

Thanks again for trying to help.

I’m using the same version for testing, but this doesn’t happen to me. Unfortunately, I don’t have any other idea for now other than the signature problem (maybe an empty signature / one that is spaces only?). If you have more insights about this happening only in specific situations (e.g. HTML vs. plain text emails), please let us know.

I use only plain text emails.
How is LangaugeTool recognizing the signature? Is it some special string/character?

Could you check whether the issue happens with HTML mails, too?


yes it does. :slight_smile:
Thanks for still trying to help me!

I have the same problem here, but when I temporarily cut the original message from my reply, LT starts to work fine on the reply and on the “On 14/03/2023 18:25, XXXXX wrote:” line.

After pasting the original message back, LT continues to work on the reply and on the “On 14/03/2023 18:25, XXXXX wrote:” line, but not on original message part !?