Back to LanguageTool Homepage - Privacy - Imprint

Standalone LT in Docker Container

I am trying to setup a docker container for the standalone version that is provided. I got the 5.7 version. I have tried a variety of options to set it up but none of it seems to work. Please help me. Thanks!

Here is my latest DockerFile that I wrote

FROM debian:stretch

RUN set -ex \
    && mkdir -p /uploads /etc/apt/sources.list.d /var/cache/apt/archives/ \
    && export DEBIAN_FRONTEND=noninteractive \
    && apt-get clean \
    && apt-get update -y \
    && apt-get install -y \
        bash \
        curl \
        openjdk-8-jre-headless \
        unzip \
        libhunspell-1.4-0 \
        hunspell-de-at
 
#ENV VERSION 5.7
#COPY LanguageTool-5.7.zip /LanguageTool-5.7.zip

#RUN unzip LanguageTool-5.7.zip \
 #   && rm LanguageTool-5.7.zip
 
WORKDIR /grammar 
#I used WORKDIR as /app /docker or no WORKDIR but none of them worked
#RUN java -cp languagetool-server.jar org.languagetool.server.HTTPServer --port 8130 --public 
CMD ["java", "-cp", "languagetool-server.jar", "org.languagetool.server.HTTPServer", "--port", "8130", "--public", "--allow-origin", "'*'" ]
EXPOSE 8130

Have you tried using one of the community-contributed Docker files? https://github.com/languagetool-org/languagetool#docker

I am looking to create a standalone version of LanguageTool. Because I am anticipating high traffic on my website, I should not go for community builds according to what I have read. I hope this clarifies my requirements. Thanks!