Back to LanguageTool Homepage - Privacy - Imprint

Test the new LanguageTool add-on for Google Docs


#21

NAVIGATION: LT finds errors, but there’s no easy way to reach the errors. Either this is broken or it’s a requested feature. As an editor, I need to navigate large documents to find the spelling/grammar mistake in the document. It’s desired to click or link to something so I can reach the error.

SPELLING SUGGESTIONS: Although there are spelling suggestions, I must manually type them into the original Gdoc. I thought double clicking would automatically overwrite my typo, but nothing happens.


(jaumeortola) #22

Once the analysis is done, you can click on any error message and the error in the text is selected. So it is very easy to reach the error. Isn’t it working for you? If your layout is complex (you have tables,etc.), it’s possible that it doesn’t work.

There is a limit for large documents, because of a server restriction. If your text is longer than 15000 characters, you need to select previously some part of the text.

Again, it should be very easy. If LanguageTool has a suggestion, just clicking on the suggestion (yellow buttons) should replace the error with the suggestion. Perhaps in documents with a complex layout it doesn’t work. Could you share some document with this problem?


(Daniel Naber) #23

Maybe we should add an icon for that? This feature is currently hidden and it’s also different from how the other add-ons work, so many users will probably not notice it.


(jaumeortola) #24

I thought it was intuitive enough, but perhaps you are right. Any idea about what icon and where to place it? The interface is already a bit cluttered.


(Daniel Naber) #25

Maybe something like http://findicons.com/files/icons/1727/yasis/22/gtk_goto_bottom.png? Not sure where to put it best.


(Giang Lê Hoàng) #26

Can I use my stand-alone version of Language Tool’s server? I want to add some more syntax on my own.


(jaumeortola) #27

You can change the LT server in the options and use your own server. But it has to be an online server, not a local server, because a local server cannot be accessed from the Google servers where the add-on is executed.

To enable using a local LT server, the add-on should be re-written and some server-side code moved to client side.


(Giang Lê Hoàng) #28

To enable using a local LT server, the add-on should be re-written and some server-side code moved to client side.

Can you modify this extension for local server accessible (I don’t know how to set up an online server…).

Thank you!


(jaumeortola) #29

It would be some work, and I am not sure if it will be viable or if there will be some downside. There is no plan to do it at the moment.


(Giang Lê Hoàng) #30

Yeah, thank you!


#31

Addon is broken:
ScriptError: Acció no permesa


(Daniel Naber) #32

I’m sorry, I cannot reproduce this. On installation, did you get a window like this and did you click “Allow”?


#33

Right! I’ve tested with another account and It works. Why doesn’t it work with my other account?
I’ve tested both accounts and it’s really strange that it works well with one and not another.

I clicked Allow in both accounts. I even tried to un-install and re-install clicking again Allow in the account that does not work.


(Daniel Naber) #34

Have you tested it with the same document? Did you have write access to the document in both cases?


#35

Yes, the same doc, write and proprietary access.


(Ruud Baars) #36

You could do that, if your local machine is a server, and you can allow outside traffic on it…


(Daniel Naber) #37

Do you have other add-on running that might interfere? If not, I’m running out of ideas what the issue might be.


#38

Wait a second, do you mean “open write access”? I’ve tried opening the doc with an access link for write access and now it works

Is this necessary?


(Daniel Naber) #39

It seems so. I just tested this, but I don’t even get the “Add-ons” menu when I don’t have write access, so I don’t get an error either.


#40

Ok, thank you. It seems that the LanguageTool must access the doc text from the outside. I thought that the permissions given during the installation process were to avoid this “write access” thing :stuck_out_tongue: