Back to LanguageTool Homepage - Privacy - Imprint

Unable to install language tool extension in ubuntu libreoffice


#1

I get this error message when I'm trying to install language tool:

(com.sun.star.uno.RuntimeException) { { Message = "[jni_uno bridge error] UNO calling Java method writeRegistryInfo: non-UNO exception occurred: java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 52.0\X000ajava stack trace:\X000ajava.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 52.0\X000a\X0009at java.lang.ClassLoader.defineClass1(Native Method)\X000a\X0009at java.lang.ClassLoader.defineClass(ClassLoader.java:800)\X000a\X0009at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)\X000a\X0009at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)\X000a\X0009at java.net.URLClassLoader.access$100(URLClassLoader.java:71)\X000a\X0009at java.net.URLClassLoader$1.run(URLClassLoader.java:361)\X000a\X0009at java.net.URLClassLoader$1.run(URLClassLoader.java:355)\X000a\X0009at java.security.AccessController.doPrivileged(Native Method)\X000a\X0009at java.net.URLClassLoader.findClass(URLClassLoader.java:354)\X000a\X0009at java.lang.ClassLoader.loadClass(ClassLoader.java:425)\X000a\X0009at java.lang.ClassLoader.loadClass(ClassLoader.java:412)\X000a\X0009at java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:793)\X000a\X0009at java.lang.ClassLoader.loadClass(ClassLoader.java:358)\X000a\X0009at com.sun.star.comp.loader.RegistrationClassFinder.find(RegistrationClassFinder.java:52)\X000a\X0009at com.sun.star.comp.loader.JavaLoader.writeRegistryInfo(JavaLoader.java:380)\X000a", Context = (com.sun.star.uno.XInterface) @0 } }

I have installed libreoffice-java-common and java environment settings for libreoffice are enabled but the problem remains.

My setup: Ubuntu 15.10, LibreOffice 5.0.2.2, Language Tool 3.2

I would appreciate any help.


(Daniel Naber) #2

You need to make sure that Java 8 is not only installed on your system but that it's also configured in LibreOffice at Tools -> Options -> Advanced.


#3

Thank you very much for your help. I've installed Java 8 and language tool works just fine.