Back to LanguageTool Homepage - Privacy - Imprint

Usage of "is" vs "are" not being flagged correctly.


#1

I noticed that languagetool does not flag improper use of “is” and “are” in several, seemingly obvious, cases.

  1. This claim are not necessary. <-- “are” should be “is”
  2. The claims in question is necessary. <-- “is” should be “are”
  3. Your services will not be severed as the claim in question are not medically necessary. <-- “are” should be “is”.

I also tried to use the rule editor but struggled quite a bit even with the examples provided.

Thanks in advance for any help or explanation that can be provided.


(Mike Unwalla) #2

Case number 2 is found by the Premium version of LanguageTool: https://languagetoolplus.com/

If you show us the rule that you tried to make, we can try to help you to make it do what you want.


#3

Thank you very much for you quick response Mike! Much appreciated.

That’s nice to hear that the Premium version captures #2. Seems I have to pay first to see additional suggestions (that one included). Unfortunately I couldn’t see that being an option with only 1 of the 3 above being caught. I did notice that grammarly caught both #1 and #2 for what it’s worth.

As for the assistance with the rule; I really appreciate you offering to help. At this point I don’t really have anything viable worth showing but am continuing to investigate.

If you had any ideas that were more “all encompassing” vs specific to the above case I’d appreciate any guidance.

Again, thanks for your attention.


(Mike Unwalla) #4

Er, so did I.
image

@dnaber , I suggest that you change the text in ‘wrong sentence’ to something like ‘Type the wrong text here’. Similarly for ‘corrected sentence’. (Or, leave the fields empty.)

Use postags (part-of-speech tags) to find classes of words. Here’s a partly-completed example for “this claim are”:

To find the postags that a word can have, in the standalone version of LanguageTool, type the word and click Ctrl+T. The Tagger Result shows:

claim[claim/NN:UN,claim/VB,claim/VBP,<S>,B-NP-singular|E-NP-singular]

I suggest that you look at the rules in grammar.xml to see examples.

That’s probably sufficient to get you started.


(Mike Unwalla) #5

Correction: in the screen shot, token 3 ‘word’ field should be: are|were


#6

Thank you Mike for all the assistance above; it has helped a great deal! Sorry it took so long to get back to you.