Back to LanguageTool Homepage - Privacy - Imprint

WARNING: unknown option: --fasttextModel WARNING: unknown option: /usr/share/fasttext/lid.176.bin

/usr/bin/languagetool --word2vecModel /usr/share/word2vec --fasttextModel /usr/share/fasttext/lid.176.bin --port 8081 --a
llow-origin "*"
WARNING: unknown option: --fasttextModel
WARNING: unknown option: /usr/share/fasttext/lid.176.bin
2021-12-02 05:37:23 +0000 WARNING: running in HTTP mode, consider running LanguageTool behind a reverse proxy that takes care of enc
ryption (HTTPS)
2021-12-02 05:37:24 +0000 Setting up thread pool with 10 threads
2021-12-02 05:37:24 +0000 Starting LanguageTool 5.5 (build date: 2021-10-02 12:33:00 +0000, 5e782cc) server on http://localhost:8081
...
2021-12-02 05:37:24 +0000 Server started

Why am I receiving these errors?

Because fasttextModel is not a command-line option but it needs to be in a properties file you specific with --config <filename>. <filename> then needs to contain fasttextModel=<path to model>.

I’ll try that. How can I check if the model is being applied?

I am now getting this error:

WARN o.l.language.LanguageIdentifier Cannot consider noopLanguages because not in fastText mode: [af, tn, xh, en]

What does your properties file look like now?

word2vecModel=/usr/share/word2vec
fasttextModel=/usr/share/fasttext/lid.176.bin

You also need to set fasttextBinary. You can call java -jar languagetool-server.jar to get usage information.

Where do I get the fasttextBinary?

Please call this command, it will print a link to FastText.

It’s working now.
Thanks

Is there a web gui when self hosting?