Back to LanguageTool Homepage - Privacy - Imprint

[DE] kritischer Fehler!

Moin liebes LanguageTool-Team

Version: LanguageTool-20200127-snapshot


Ich habe seit längeren Probleme mit dem LanguageTool, die sehr kritisch sind. Das LanguageTool hängt sich auf, was die Folge hat, dass ich LibreOffice “mit der Holzhammermethode” beenden muss, weil es überhaupt nicht mehr reagiert. In diesen Bild ist zu sehen, wie es aussieht. Ich markiere einen Teil des Text, wo was Falsches markiert wird. Danach aktiviere ich die Rechtschreib- und Grammatiküberprüfung, um die Fehler zu kriegen und hier hängt sich das LanguageTool auf.

LibreOffice reagiert auf nichts mehr und wenn man oft genug auf das “X” klickt, kann man die Rechtschreibung und Grammiküberprüfung beenden. Wenn nicht, muss LibreOffice brachial beendet werden, was zu Datenverlust führen kann. Bei mir als Beispiel könnte ein ganzes Kapitel fehlen. Bei anderen viele Textstellen, die für die Arbeit wichtig sind.

Bisher hatte ich keinen Datenverlust, weil ich die Überprüfung immer abbrechen konnte, aber wenn der Fehler nicht behoben oder sich verschlimmert, könnte ich mir vorstellen, dass es zum Totalabstürzt kommt und LibreOffice mit in dem Tod zieht, wodurch es zum Datenverlust kommen kann.

Das verwendete Dokument:S4 League Forever 02 Band 7.zip (27.1 KB)
Das Dokument ist sehr klein und selbst dann kommt der Fehler vor. Ihr könnt es zum Testen verwenden und für die Entwicklung weitergeben.

Ich bitte um Hilfe, denn dieser Fehler sorgt dafür, dass ich zwar sehe, dass ich einen Fehler mache, aber nicht welchen. Ich muss den Text immer kopieren und auf der Homepage einfügen, was ich nur mache, wenn ich den Verdacht habe, es handelt sich um einen Fehlalarm, der möglichweise in einer neuren Version gefixt wurde.

Grüße Dallun511

Ich kann das Problem nicht nachvollziehen. Bitte gib bei allen solchen Bug-Reports an: welche LibreOffice-Version benutzt wird und ob das Problem reproduzierbar ist (also ob es wieder passiert, wenn man die gleichen Aktionen nochmal durchführt) und wenn ja, wie ganz genau (welcher Text muss markiert werden etc.).

Okay, ich werde jetzt immer die LO-Version angeben.

LO-Version 6.3.4.2 x64

Der Fehler ist reproduzierbar und keine Seltenheit.

Schritt: 1 Um den Fehler zu reproduzieren, muss das Dokument geladen werden. Danach beginnt das LanguageTool normal seine Fehleranylse.


Schritt: 2 Den Text herunterscrollen, bis zu einer Textstelle, die blau makiert ist. [Wie im Bild]
Danach die Stelle mit der Maus makieren und dann Extras -> Rechtschreibprüfung… klicken.

grafik
Ergebnis Dann hängt sich das LanguageTool auf.
Sollte das LanguageTool das gewünschte Feedback geben, als Beispiel eine Kommaregel oder der Artikel stimmt nicht mit dem Nomen über ein, die Schritte wiederholen und es mit einer anderen blaumakierten Textstelle probieren, bis es sich aufhängt.

Bei meinem erneuten Durchlauf passierte es beim dritten Versuch.

Grüße Dallun511

Eine Version 6.3.2.4 finde ich online nicht, wenn ich es mit 6.3.2.2 teste, passiert bei mir kein Absturz. Ich habe es mal allen Fehlern versucht. Vielleicht hat @Fred.Kruse eine Idee.

Tut mir leid, ein Zahlendreher.
LO-Version 6.3.4.2
grafik

Auch damit kann ich es leider nicht nachvollziehen. Es wäre interessant zu wissen, was der Taskmanager im Moment des Absturzes sagt. Verbraucht LT Rechenzeit und/oder LibreOffice?


CPU ist zwischen 6,6 bis 8,8 %
RAM-Verbrauch ist konstant

Was braucht ich normal, um den genauen Verbrauch vom LT zu erfahren?

Ich dachte, LT wäre als eigener Prozess aufgelistet, aber das scheint nicht der Fall zu sein. Leider werden wir wohl erst weiterkommen, wenn ein Entwickler das Problem reproduzieren kann. Es muss auch nicht an LT liegen, es kann auch ein LibreOffice-Bug sein.

Sollte es ein LO-Bug sein, kann ich ewig warten. Da sehe ich keine Hoffnung.

Auch ich habe es getestet und kann den Fehler nicht nachvollziehen. Ich arbeite allerdings mit der Version 6.2.8.2. Da tritt der Fehler nicht auf.
Vielleicht solltest du versuchen mit einer älteren Version von LibreOffice zu arbeiten.

Werde ich mal machen.


Ich habe ein Downgrade vollzogen, weil mich die Bugs sehr genervt haben. Aber trotzdem ist der Bug vorhanden und das auch noch schlimmer. Jetzt nämlich geht nichts mehr. F7 und Abstürz bzw. aufgehangen. Es hilft nur noch der TaskMGR und Taskkill.

@Fred.Kruse @dnaber
LO-Version: 6.2.8.2
grafik
Java-Version: 13.0.01 (64x)

LT: LanguageTool-20200320-snapshot (20.03.2020)

LO-Benutzer-Odner wurde komplett neu aufgesetzt.

Jetzt weiß ich nicht mehr weiter. Noch weiter zurück? Oder habt ihr noch andere Vorschläge.

Grüße Dallun511

Es tut mir leid, den Fehler kann ich nicht nachvollziehen. Ich habe dafür auch keine Erklärung. Ich habe eine niedrigere Java-Version 11.0.x, aber daran kann es nicht liegen. Funktioniert denn die Rechtschreibprüfung, wenn LT nicht installiert ist?
Vielleicht hilft LO ganz zu deinstallieren, LO-Benutzer-Ordner ganz zu löschen und dann alles neu zu installieren.

@Fred.Kruse
Ich habe LO komplett deinstalliert und den LO-Ordner gelöscht, was ich oben erwähnt habe.
Deswegen weiß ich nicht mehr weiter. Ich habe alles gemacht, was in meiner Macht steht. Die Rechtschreibprüfung kann ich gerne testen.

Ohne LT funkioniert die Rechtschreibprüfung problemlos
grafik
Ich musste nur ein Wörterbuch kappen, weil sonst die Rechtschreibprüfung ewig suchen müsste. Das Dokument hat schließlich 240 Seiten.

Das Problem liegt an LT, denn ohne LT funktioniert alles.
Hm! Irgendwelche Ideen?

Zur Erinnerung: LO 6.3 deinstalliert und 6.2… wurde installiert.
Der LO-Ordner wurde gelöscht und neu aufgesetzt.
Es wurde die aktuellste LT-Version installiert.

An fehlender Rechnenpower kann es nicht liegen, denn ich habe einen Ryzen 7 2700X und 16 GB RAM 3200 MHZ.

Wenn ihr Ideen habt, nur herdamit ich probiere alles aus.

Du könntest noch mal versuchen die Version 4.8 zu installieren. Es wäre interessant, ob die läuft.

grafik
Du wirst lachen, aber die funktioniert einwandfrei.

@Dallun511 Kannst du mal diese Version testen? https://we.tl/t-kKghCvzdRj - das ist die aktuelle mit Fixes von gestern Abend.


Version 4,8 funktioniert auch bei größeren Aufgaben, ohne Probleme.

@dnaber das werde ich sofort testen.

P.S. unten ist auch eine Kurzfassung

Zunächst funktioniert die Version, nur sehr langsam. Ich warte auf der Herausgabe für einen markierten Satz circa drei Zeilen circa 5 bis 10 Minuten. In LT 4,8 zum Vergleich nur eine Minute.

Leider scheint sich trotzdem die Analyse komplett aufzuhängen oder dauert zu lange für ein wenig Text.

Es kam eine Aussage nach sehr langer Wartezeit.
grafik
Ich muss leider sagen, dass diese Ausgabe nicht zufrieden stellen ist.
Weil das nicht der markierte Text war.


Das war der martkierte Text, der analysiert werden sollte.


Hier die Textstelle, die das LanguageTool als Fehler gefunden hat.


Das ist ganz am Anfang des Kapitels. Dabei handelt es sich auf noch um einen Fehlalarm. Nach der wörtlichen Rede wird großgeschrieben. Dieser Fehlalarm kommt in meinem Roman dutzende Male vor. Ich konnte diese nur nie zeigen, weil die Analyse sich entweder aufhängt oder keine Aussage überhaupt zeigte.


Die Webseite zeigt keinen Fehler an, weswegen das Problem mit LibreOffice zusammenhängt.

Das sind die Einstellung von mir:

Diese wurden nicht verändert. In LT 4,8 liefen sie ohne Probleme.

Mit dem Snapshot von 4,9 von @dnaber gibt es Fehlalarme und die Analyse ist total langsam und analysiert nicht mal die Textstelle, die ich markiert habe.

LT 4,9 scheint ersthafte Probleme zu haben, die angegangen werden müssen. Ich habe LO Version: 6.2.8.2 (x64) für diese Test genutzt. LT 4,8 funktioniert schnell und ist zuverlässig. LT 4,9 Snapshot ist dagegen verbugt, langsam,hängt sich gerne auf und provoziert Fehlalarme, die vorher nicht da waren.

Beispiele:
In LO:
grafik
auf der Homepage

Nozomi sagte nachdenklich: „Sie wurde wohl befummelt oder hat sich ausgezogen. Egal. Ich hoffe, sie schläft durch.“

In LO:
grafik
auf der Homepage:

Der Mann sagte gelangweilt: „Diesen Satz habe ich sehr oft gehört, aber egal.“ Er gab den Kellner den Becher und übergab ein sehr dickes Trinkgeld.

Kurzfassung:
LT 4,8 funktioniert sehr gut, ist schnell und analysiert nur die von mir markierten Textstellen.
LT-Snapshot 4,9 funktioniert mit vielen Problemen, ist langsam, hängt sich gerne auf und analysiert nicht die von mir markierten Textstellen und produziert Fehlalarme, die in LT 4,8 nie existiert haben.

Irgendwelche Fehler haben sich in der Entwicklung von 4,8 auf 4,9 eingeschlichen, die diese Probleme verursachen. Die Frage, die wir uns stellen müssen, ab wann hat das angefangen und wie leicht kann man dieses Problem lösen. Ich finde nur nicht, dass man deswegen 4,9 verschieben muss, da bisher nur ich ganz stark betroffen bin.

Ich hatte schon mal einen gravierenden Bug, der mit einem Snapshot gefixt wurde. Ich kann ruhig warten. Zum Testen bin ich gerne bereit.

Grüße Dallun511