Back to LanguageTool Homepage - Privacy - Imprint

Grammar checker doesn't work for russian language on english version of windows


(Sergey) #1

On my laptop installed English version of windows 8.1.
I installed libreoffice 4.4.2.2, then I installed the add-on running languagetool 2.9. The grammar checker for Russian language does not work. Then I read the documentation and have disabled:
* Lightproof grammar checker (Russian)
* Lightproof grammar checker (English)

However, the grammar checker only works for English. Spell check works for the Russian language and the English language. I made a screenshot of the Writer with the text and attached to this message. Please help in configuring.


(Daniel Naber) #2

Hi, thanks for your report. Have you made sure the error gets detected by LanguageTool, e.g. by pasting the same text into the check box at https://languagetool.org? If so, could you post a small example document?


(Sergey) #3

Thank you for the prompt response.

Screenshot of LanguageTool.org:

Example file.


(Daniel Naber) #4

Well, it works for me with LibreOffice 4.4.0.3. Did you restart LibreOffice after installing LanguageTool? Does it help if you make a small change to the Russian sentence, to trigger a new check?


(Sergey) #5

Yes. Just in case, I even rebooted the laptop.

No. :frowning: I wrote a fairly large text, but the grammar checker for Russian language does not work.

Also I tried to update Java. Now LibreOffice uses the Java build 1.8.0_45-b14.

I used running languagetool on another computer with the Russian version of Win7. There everything worked fine.

If you want to do any tests, I am ready to do them on my laptop.


(Yakov) #6


Скорей всего LanguageTool не включён в настройках для русского языка.

Сервис- Параметры- Настройки языка - Лингвистика - Доступные языковые модули - Правка -

(выбираем русский язык) и проверяем настройки модулей
LanguageTool должен быть включён,
а LightProof выключен.

После изменения настроек необходимо закрыть все окна LibreOffice (включая и быстрый запуск).


(Sergey) #7

Действительно он был отключен. Спасибо большое, ваш совет мне помог!

Это действие было нетривиально для рядового пользователя. Почему бы при установке не активировать LT для всех языков?

P.S.: LT замечательный инструмент, поэтому пользуясь LibreOffice всегда после его установки, устанавливаю LT. Надеюсь, в обозримом будущем планируется внедрить LT в сборку LibreOffice.


(Sergey) #8

dnaber, the problem was solved after Yakov's advice. The problem was that for the Russian language by default LT was turned off and about this option I just didn't know. I think it is because I have a laptop with installed English version of windows 8.1

LT is a wonderful and extremely useful tool. I hope in future versions it will be enabled for all languages by default. Also hope that LT will be added to the build of LO. :smile:


(Kate) #9

Добрый день. А вы можете мне подсказать, где что включить? У меня тоде не исправляет русский язык. В каких настройках это можно найти? Спасибо.


(Yakov) #10

Посмотрите этот совет для включения проверки грамматики (синее подчёркивание)

Для включения проверки орфографии (красное подчёркивание) должен быть установлен словарь. Например, этот https://extensions.libreoffice.org/extensions/russian-dictionary-pack