Back to LanguageTool Homepage - Privacy - Imprint

Latest languagetool addon not work with 7.4.x

I use the latest LibreOffice 7.4 and i can not install the languagetool addon. Get always error. With latest LibreOffice 7.3 working fine.

1 Like

Thanks for the warning. So I will wait a bit with the switch to LibreOffice 7.4 and stay with version 7.3 for now.

LibreOffice 7.4 now supports LanguageTool natively. You can run a local server following these instructions and configure LibreOffice to use it using these instructions

I will not make a owen server. I will only use in LibreOffice, not more without making a Server.

Why?

Since I just couldn’t resist to personally test if the LanguageTool extension works with LibreOffice 7.4, I installed the new LibreOffice version on my iMac today. On macOS, LanguageTool 5.8 works fine with LibreOffice 7.4, and I have not had any error messages so far.

Version: 7.4.0.3 / LibreOffice Community
Build ID: f85e47c08ddd19c015c0114a68350214f7066f5a
CPU threads: 4; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: nl-NL (nl_NL.UTF-8); UI: nl-NL
Calc: threaded
Java version: Eclipse Temurin 17.0.4 by Adoptium

Other people also got problems with LO 7.4 and LT 5.8, see here: LibreOffice extension crash

The solution by Fred.Kruse works (comment 2): Use the snapshot build .oxt that fixed the problem of the extension.