Back to LanguageTool Homepage - Privacy - Imprint

Leading and trailing spaces added when pasting

Hi,

I switched from Grammarly a month ago, and I like LT so far. But there’s an annoying feature: The extension adds leading and trailing spaces to the texts I paste. Most of the time, I can paste as text to get rid of these extra spaces. But when I want to keep the layout and hyperlinks, for example, that becomes a nuisance.

I ran some tests and this behavior appears only when LT is enabled - I’m using Brave browser.

It happens in Basecamp mostly, our project management platform. I read another thread about that Basecamp here: Bug: (copy-)Paste replaces whole line instead of adding but I’m not sure if it’s related.

  1. Is it a known “bug”?
  2. Is there any option I can tweak to fix this?

Thanks.

Hi, could you check whether this is specific to Brave?

Hi dnaber, It’s not specific to Brave. I tried with Edge and could reproduce the behavior.

Thanks, could you also send a screenshot and a short text that we can use to reproduce the problem?

I made a quick video: Dropbox - lt-bug.mp4 - Simplify your life

At the beginning, there are no leading and trailing spaces on my texts. But after I paste them, there are (I highlighted them). Even line breaks with bullet points.

This is for a to-do creation, but the behavior is the same with messages, comments and pings.

Thanks, I’ve created a ticket for our developers for this problem.